Elitebook 840 G4 Suspend

  • Hallo,


    Ich hab ein Elitebook 840 G4, installiert ist ein Ubuntu 17.10.
    Leider funktioniert bei mir der Suspend-mode nicht, nach dem Aufwecken läuft nur der Lüfter auf hochtouren, es kommt aber kein Bild mehr.
    Das Bios ist das aktuellste, von 07/12/17.


    Kennt vielleicht jemand einen Workaround bzw. kann man im Bios noch etwas tunen?

  • Ich habs aufgegeben, ich bleib bei meinem Folio 9470m von 2013.
    Die CPU vom Folio ist zwar um ca. 10 Prozent langsamer, aber dafür läuft Linux wirklich rund.

  • Ich weiß was Du meinst.
    Leider sind die ACPI-Tabellen der UEFI Version P78 nur auf Windows ausgelegt und produzieren einen Haufen Log-Spam.
    Ich habe Roman von HP bei demselben Problem gerade helfen können.
    Die G4 Elitebooks scheinen vom Werk mit dem Bios V1.06 ausgeliefert zu werden. Diese lassen Linux glauben, dass ein Wake-Up nicht unterstützt wird.

    Code
    1. kernel: pci 0000:00:14.0: System wakeup disabled by ACPI

    Ein Update auf 1.08 löst das Problem zumindest auf einem 840 G4 und ZBook 15u G4
    Hoffe das hilft Dir. (Und ja, mein 2013er Elitebook 850 G1 hat die Probleme auch nicht. ;) )
    lg

  • Hallo. Habe das selbe Problem, allerdings finde ich auf der HP-Support Seite (noch) keine Bios-Updates. Wo hast du denn die Bios Version 1.08 gefunden? Ein Link wäre super! Danke und lg

  • Gerne, hier ist der Link.
    Please login to see this link.
    Allerdings liegt das Update Paket nur als exe vor.
    Ich hab es in einer VM entpackt. Danach liegt in C:\SWSetup und der Nummer des Pakets die Datei P78_0108.bin
    Diese muss dann auf einen FAT32 formatierten USB Stick in den Pfad
    /Hewlett-Packard/BIOS/New/P78_0108.bin
    kopiert werden. Anschließend kann das BIOS über die Option "Lokales Medium" aktualisiert werden.
    Lieder ziemlich umständlich, aber es funktioniert zumindest.
    lg