HP Elitebook 745 G5 can t get Fedora or Ubuntu on it damn

  • Tried several things so i ll just try to fish for solutions here. Anyone who had the same problem and solved pretty quick?


    I ll give an update ofc if i ll be the first one to find it out :wacko:

  • I am giving up. I even contacted the HP support, it was the worst experience i had since years. This Notebook is trash and it s going back for sure. Back to Lenovo i would say with no headache.


    What i tried so far:


    Google for the specific problem till page 15
    Google for the specific problem of the specific notebook till page 5
    Google for problems that could be related to it
    Every permutation in the BIOS also rolling back 1 version and then again every permutation....
    contacted the support which is a zero, nada worse than zero
    Tried 9 different Linux Versions around 21 different total versions , debian had the new Kernel so i had hope there. I even somehow managed to get kernel 5 and 5.01 on Ubuntu but even then i just got more problems.
    Many unrelated things that could somehow magically solve the problem


    And by the way this problem seems to exist since a longer period with the specific HP notebook but HP can t manage to get it solved since months.

  • Fix:
    i changed everything to uefi disabled legacy , enabled Secure boot



    -Under the Advanced settings somewhere in the bios you ll find "ROM
    Policy blabla" just switch from ALL LEGACY to ALL UEFI and boom it works
    with 18.04. ( Actually it works with everything no mce=off or anything
    else required in the boot params)



    But nevertheless the HP support was horrible and i still don t recommend the step buying a HP notebook.